Linux   发布时间:2022-04-01  发布网站:大佬教程  code.js-code.com
大佬教程收集整理的这篇文章主要介绍了poj 3186 Treats for the Cows(dp)大佬教程大佬觉得挺不错的,现在分享给大家,也给大家做个参考。

概述

Description FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a g

Description

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time. 

The treats arE interesTing for many reasons:
  • The treats are numbered 1..N and stored sequentially in single file in a long Box that is open at both ends. On any day,FJ can retrieve one treat from either end of his stash of treats.
  • Like fine wines and delicIoUs cheeses,the treats improve with age and command greater prices.
  • The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
  • Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their Box,what is the greatest value FJ can receive for them if he orders their SALE optimally? 

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.

Input

Line 1: A single Integer,N 

Lines 2..N+1: Line i+1 contains the value of treat v(i)

Output

Line 1: The maximum revenue FJ can achieve by selling the treats

Sample Input

5

1

3

1

5

2

Sample Output

43

Hint

Explanation of the sample: 

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2). 

FJ sells the treats (values 1,3,1,5,2) in the following order of inDices: 1,2,4,making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.
 
题意:给你一组序列 只能从左端点 或者 右端点 选取一个数乘上选取它的天数 得到一个最大 权值和
思路: dp[i][j] 表示第i个物品 选取j个左边的物品 的最大权值
#include<cstdio>
#include<cString>
#include<algorithm>
#include<iostream>
#include<String>
#include<vector>
#include<stack>
#include<bitset>
#include<cstdlib>
#include<cmath>
#include<set>
#include<list>
#include<deque>
#include<map>
#include<queue>
#define ll long long int
using namespace std;
inline ll gcd(ll a,ll b){return b?gcd(b,a%b):a;}
inline ll lcm(ll a,ll b){return a/gcd(a,b)*b;}
int moth[13]={0,31,28,30,31};
int dir[4][2]={1,0,1,-1,-1};
int dirs[8][2]={1,1};
const int inf=0x3f3f3f3f;
const ll mod=1e9+7;
int a[2007];
int dp[2007][2007];
int main(){
    ios::sync_with_stdio(false);
    int n;
    while(cin>>n){
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++){
            cin>>a[i];
        //    sum[i]+=a[i];
        }
        dp[1][0]=a[n];
        dp[1][1]=a[1];
        for(int i=2;i<=n;i++){
            for(int j=n;j>=n-i+1;j--)
            dp[i][0]+=(a[j]*(n-j+1));
            for(int j=1;j<=i;j++){
                if(dp[i-1][j-1]+a[j]*i<dp[i-1][j]+a[n-(i-1-j)]*i){
                    dp[i][j]=dp[i-1][j]+a[n-(i-1-j)]*i;
                }else{
                    dp[i][j]=dp[i-1][j-1]+a[j]*i;
                }
            }
        }
        int ans=-inf;
        for(int i=0;i<=n;i++)
            ans=@H_540_81@max(dp[n][i],ans);
        cout<<ans<<endl;
    }
    return 0;
}

大佬总结

以上是大佬教程为你收集整理的poj 3186 Treats for the Cows(dp)全部内容,希望文章能够帮你解决poj 3186 Treats for the Cows(dp)所遇到的程序开发问题。

如果觉得大佬教程网站内容还不错,欢迎将大佬教程推荐给程序员好友。

本图文内容来源于网友网络收集整理提供,作为学习参考使用,版权属于原作者。
如您有任何意见或建议可联系处理。小编QQ:384754419,请注明来意。