Linux   发布时间:2022-03-31  发布网站:大佬教程  code.js-code.com
大佬教程收集整理的这篇文章主要介绍了POJ - 3186 Treats for the Cows(dp)大佬教程大佬觉得挺不错的,现在分享给大家,也给大家做个参考。

概述

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period
FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time. 

The treats arE interesTing for many reasons:
  • The treats are numbered 1..N and stored sequentially in single file in a long Box that is open at both ends. On any day,FJ can retrieve one treat from either end of his stash of treats.
  • Like fine wines and delicIoUs cheeses,the treats improve with age and command greater prices.
  • The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
  • Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their Box,what is the greatest value FJ can receive for them if he orders their SALE optimally? 

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.

Input

Line 1: A single Integer,N 

Lines 2..N+1: Line i+1 contains the value of treat v(i)

Output

Line 1: The maximum revenue FJ can achieve by selling the treats

Sample Input

5
1
3
1
5
2

Sample Output

43

Hint

Explanation of the sample: 

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2). 

FJ sells the treats (values 1,3,1,5,2) in the following order of inDices: 1,2,4,making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.
 
题意:每次可以从两端取一个数,假设取得数是 x ,这是第 i 次取,那么可获得价值 i * x,问最后最大价值是多少。
。。。设 dp[i][j] 表示在左边去 i 个,右边取 j 个获得的最大价值,那么有状态转移方程:
dp[i][j] = max(dp[i - 1][j] + val[i] * (i + j),dp[i][j - 1] + val[n - j + 1] * (i + j))
并设初始状态  dp[i][0] (i 从 1 到 n),dp[0][j] (j 从 1 到 n)
 
#include<cstdio>
#include<iostream>
#include<algorithm>
#define debug(X) cout << "[" << #x <<": " << (X) <<"]"<< endl
#define pii pair<int,int>
#define clr(a,b) memset((a),b,sizeof(a))
#define rep(i,a,b) for(int i = a;i < b;i ++)
#define pb push_BACk
#define MP make_pair
#define LL long long
#define ull unsigned LL
#define ls i << 1
#define rs (i << 1) + 1
#define INT(t) int t; scanf("%d",&t)

using namespace std;

const int maxn = 2e3 + 10;
int dp[maxn][maxn];
int a[maxn];

int main() {
    int n;
    while(~scanf("%d",&n)){
        for(int i = 1;i <= n;++ i)
            scanf("%d",&a[i]);
        dp[1][0] = a[1];
        dp[0][1] = a[n];
        rep(i,2,n + 1) dp[i][0] = dp[i - 1][0] + a[i] * i;
        rep(i,n + 1) dp[0][i] = dp[0][i - 1] + a[n - i + 1] * i;
        for(int i = 1;i <= n;++ i)
            for(int j = 1;j <= n;++ j)
                dp[i][j] = max(dp[i - 1][j] + a[i] * (i + j),dp[i][j - 1] + a[n - j + 1] * (i + j));
        int ans = 0;
        for(int i = 0;i <= n;++ i)
            ans = max(ans,dp[i][n - i]);
        cout << ans << endl;
    }
    return 0;
}

大佬总结

以上是大佬教程为你收集整理的POJ - 3186 Treats for the Cows(dp)全部内容,希望文章能够帮你解决POJ - 3186 Treats for the Cows(dp)所遇到的程序开发问题。

如果觉得大佬教程网站内容还不错,欢迎将大佬教程推荐给程序员好友。

本图文内容来源于网友网络收集整理提供,作为学习参考使用,版权属于原作者。
如您有任何意见或建议可联系处理。小编QQ:384754419,请注明来意。